Can not work ATH command on SIM800C


#1

Hi All,

I initiate call with ATDxxx;
Until called party answeres or time-out, module does not respond any AT command.
No response even if I send “ATH” command.
After called party answered (conversation starts with no problem), call can be disconnected with ATH command.
Once call released either with timeout or with ATH command after answer module continues to work in the same way.

A bit about hardware;

  • MCU supply is 2.8V
  • DTR pin of SIM800C is connected to GND.
  • Decoupling tantalum capacitor in 3mm distance
  • Used PSU is capable of driving 3A.

I tried;

  • Changed module (with the same and different production dates), MCU, card… everything.
  • If I connect Rx-Tx pins to SIM900D with the same software it works properly.

Any assistance highly appreciated.


#2

Looks like it has sleep mode enabled. Check if you are sending any of the AT+CSCLK commands.


#3

Thanks for answer. I found the reason after a lot headache.

My software is based on existing project which has been written for SIM900D.
During init, “AT+COLP=1” command was sent. This command disables module reply or accept any command during GSM call before answer.

Strange thing is SIM900D accepts ATH command while called party rings. Leaving module in default or sending “AT+COLP=0” solved my problem.


#4

Thanks for updating and glad you solved it. :slight_smile: