Can we use normally available and used airtel 4g SIM in gsm Module sim800L?

I am using the sim800 L gsm module and in which i have used airtel 4g prepaid SIM. But when activating the module using 3.7V 1500 mAH LIPO battery. The LED in the GSM module is blinking every second but not every 3 seconds. Can anyone tell me whats wrong here?

SIM800L is support only 2G services . check it by another 2G card if its not getting network so connect GSM antenna.

I use Airtel 4G SIM and Vodafone 4G sim cards. They default to 2G network and work fine. But i have observed problems with old type SIM cards written 64K on them.
Try newer sim cards, they should work fine. There might be other problems as well, Check antenna connections and band settings. Make sure the command AT+CBAND? retuens EGSM_MODE,ALL_BAND

Why I raised this issue is because earlier(I mean 2 -3 weeks ago) I didn’t faced any issue with network connectivity but was facing issue with AT command response. There were garbage values response. I tried with every possible baud rates but no luck. So later I found that it might be because of the RST pin in gsm module I left blank.

So I decided to use 3.3V for RST pin. But now I am struggling with the network connectivity. Yes I am using latest Airtel prepaid 4g sim .

Please help me here . it doesn’t seems I have missed anything here. If required I can post a video of all my approach I have made.

OK, you can share a video on youtube and post link here showing the connections and power source and all.

Here is the YouTube link:

Are you sure, the SIM direction you inserted is correct? Verify once.
And the battery you are using, check if its voltage is charged to 3.7V to 4.2V.
You cannot connect 3.3V lines or 5V arduino lines directly to module. All 3 lines need level translation to 2.8V of GSM module. You connecting 3.3V might damage the module.
Use short wires for battery connections.

Yes I have checked sim is inserted properly. The battery measures 3.6V ~3.7V . How to do level translation? Please give me the circuit diagram . Wires are short as I am using jumper cables only.

hello Gaurav Mishra did you fix that GSM network issue?

I have used an airtel 4G sim with sim 800L module.
the error i get is

 Command timed out: AT+CGDCONT=1,"IP",""

Is there anything that can be done to make it work

May be your code sending the command is waiting for a response. You need to observe the terminal capture to see whats happening. May be module is responding with ERROR and your code might not be handling it.
Check the terminal capture on UART lines of modules. Arduino terminal is not helpful as it doesnt show whats coming from module.

Have you figured out the issue. ? This problem is bcz of your lipo Battry. Sim800l is restarting for sure. The voltage should be 4 to 4.1 if it is less of more then brownout triggers. U can test this using an terminal.

1 Like

Ravi sir my gsm sim 800l not geting network iam using bsnl 3g sim card and giving power from arduino 5v using 1N4007 diode it blinking erery one second plz tell me what is the problem

It is not the problem with the sim card . It is the problem of power supply you have to solder a 1000uf 10v capacitor with vcc and gnd of arduino. I was also having same problem but this method has worked