Firmware upgrade for sim808 module

firmware
sim808

#1

hello I have sim808 module and I want to upgrade my firmware
I have seen your video but something is not clear for me or maybe I’m doing something wrong
the module has a USB interface
and when i connect it to PC it keeps making voices of plugged in plugged out non-stop
and when i click start download it doesn’t give any respond
so what am I missing here?
do I have to connect a battery ? module has interface for lithium batter and I have a 3.7v battery with ready connector
best regards Mr.Ravi


#2


this is the firmware image I got from simcomm after your help
when I connected external battery to the module it doesn’t plug in / out all the time like before
but it doesn’t download the firmware to the module


#3

If you are getting Plug in or out messages, may be your USB cable is loose or driver not installed.
Yes VBATT pins should be at 4V when you are performing upgrade.


#4

it stopped doing in/out when i plugged the battery
it’s 3.7v
and here’s my connection
i connect battery first (no LEDs work)
then i connect usb to pc ( LEDs work but download doesn’t work as shown before)
my cable is not loose i tried many cables and it was same and i tested the cable with some smart phones and no problem with it .


#5

After you pressed START, did you press the PWRKEY pin to GND?


#6

no I didn’t press anything , I thought I read somewhere I don’t need to press anything
what should I do exactly ?


#7

oh it somehow worked maybe after i pressed powerkey
I suddenly found 100% and DL ok
thanks a lot man


#8

I found the problem
I was connecting usb then click download
so to make it work throught usb :
1- connect battery
2- connect usb to sim808 module but not to pc
3- open the download tool and choose target : sim808 port type : usb and browse for image .cfg
4- then click Start Download
5- connect usb to pc and it will start auto and wait until it gets 100% and says DL OK


SIM900A firmware update issue
#9

now I want to test some ATC using the same connection with USB
is this possible ?
and is there any desktop at command tester I can use ?


#10

Glad it worked :slight_smile:
Thanks for sharing the solution
I dont think you can send AT commands through USB port, May be newer SIM7000 modules allow it. But i dont think SIM808 does.


#11


yea thanks a lot to your videos
and about this , does this mean USB doesn’t support AT Command testing?
and what’s the h/w UART connection to the module if usb won’t work?


#12

Welcome and do contribute to the forum in free time :slight_smile:
No it doesnt support AT command testing
There are UART lines TXD and RXD which are used to send AT commands.


#13

I do whenever I can , You did help me many times and I’d like to do same to others when I can
I connected the tx , rx , Gnd from the module to rx , tx , Gnd of a usb-serial (TTL) and i connected the usb to the pc and the battery to the sim808 module battery connector but it’s not working
also after waiting more than a month for the new firmware and finally have it
the AT+CLBS still not working for me and I have no idea why :frowning:
I wish I could check if my current firmware version supports this command or not
but the command is released in GSM location app notes in 2015
and the firmware version is 2016 idk what’s wrong


#14

Ok. You mean AT commands are not working?
Are you able to get any basic AT commands running?
Or UART itself not working?

The year doesn’t make difference, the firmwares are released with different features enabled and some disabled.
USB need not be connected anymore after firmware update.
Are you using appropriate level translation between GSM and USB-Serial?


#15

my sim808 module is connected to arm cortex-m7 same70 microprocessor
all AT commands are working except the CLBS commands , even the old CIPGSMLOC is working
even my GPS connected to the sim808 is working perfectly while all CLBS commands getting me an error
I’ll provide you with screenshot from the terminal soon
this is the app note for gsm location via CLBS release date and my current firmware date


#16


#17

What is this AT_COMMAND_ ?
Just capture the real command flow, i think this is formatted command capture from code.
And you are running off a discharged battery, 3.5V is too low.


#18

i’m disabling echo so the commands I do are not shown
the AT_COMMAND_ is just a printf under each command case to show me which command is used now
but what after it is the real response from uart handler
yea I forgot to turn off yesterday and battery almost empty now but yesterday it was on 50% and I had same results and the fact that CIPGSMLOC is still working means that CLBS will not work cause both are gsm location app notes so it can’t be both can work same time


#19

Hi…in my case the problem is module of type 2 are working good with the AT+NETOPEN command
But, the modules of type 2 are responding with ERROR.So, we want to change the firmware of SIMCOM modules of Type 1 as Type 2 .Please provide the information to upgrade the firmware.Please tell us how to upgrade the firmware.

pcb assembly company