GSM Module SIM800L - Sim not getting registered

sim800l

#1

Hello,
I am working on GSM SIM800L along with Teensy 3.2 microcontroller. I have done the connections and I can see the Netlight LED blinking. The rate at which it is blinking is quite fast and I think that it is not registered to the network.

Observations:

  • I cant make calls to the number. It says not reachable.
  • Led is continuously blinking, so I think it is not a power issue.
  • I have established connection between the GSM and controller. I can see the proper response of basic AT commands in the Arduino Serial Monitor.
  • I am getting Response ‘Error’ on sending SIM related AT commands.

Also, I am working on a SIM which has a PIN lock. Is it due to this that my SIM is not getting registered to the network?
How can I fix this?

Thanks in advance!!


#2

There can be many reasons,
SIM lock can be one of them.
You can first try using AT+CPIN command to enter password for unlocking sim. Read more about it in the AT command manual. Once you eliminate this issue, you can proceed further with diagnosing other possible problems.


#3

@RaviPujar - Thanks, it works now!!


#4

i am also getting the same error. but the sim card with sim800A works fine without any password requirement. it gives error only when it with sim 800l mini.
please help.