HELP! Firmware update for SIM5300EA


#1

Hi all,

I am not able to flash a new firmware to SIM5300EA module. The USB AT port is not detected as it is said in the documentation “SimTech HS-USB AT Port”, when I connect the module with USB I can only see normal COM ports (COM1…) in my device manager and still can send AT commands and receive responses from the module using one of these, but for firmware updating it’s not working. Another thing is that in device manager there is an unknown device called “Comneon Suspend” and when I check my USB viewer it indicates that the driver for your SIMCOM PRODUCT is not installed. I tried to install all the drivers that I found on internet related to SIMCOM 53xx family but nothing works.
I was facing the same issue with SIM7000G but it was solved easily by installing the USB driver.
I use SIM5300EA-TE-KIT.

Any help will be so much appreciated!


#2

You need to install SIMCOM USB drivers for SIM5300EA i think. Drop a mail to local SIMCOM support in your country, they will send you link to download.