HTTP post with SIM7100 module

I would like to post data using sim7100, what are the At commands to connect the device to internet and post using HTTP post

Did you try the command example given in manual?
http://simcom.ee/documents/SIM7100E/SIM7100_AT%20Command%20Manual_V1.00.pdf
Page number 418.

its showing error,
How can i connect it to internet?

Thats a very broad question, Ask specific questions with more details where or when you are getting error.
I guess you have to use the TCP enabling commands to connect to internet.

How to can i use like this in sim7100E ???

AT+SAPBR=3,1,“Contype”,“GPRS”

AT+SAPBR=3,1,“APN”,“www”

AT+CSTT=“live.vodafone.com

AT+SAPBR=3,1,“APN”,“live.vodafone.com

AT+SAPBR =1,1

AT+SAPBR=2,1

AT+HTTPINIT

AT+HTTPPARA=“CID”,1

AT+HTTPPARA=“URL”,“http://xyz.io/api/post.php

AT+HTTPPARA=“CONTENT”,“application/x-www-form-urlencoded”

AT+HTTPDATA=192,15000

328485C0

AT+HTTPACTION=1

AT+HTTPREAD

AT+HTTPTERM

These commands wont work with SIM7100 since its a older module. These will work with SIM7000.
You should use TCP commands for SIM7100

Please suggest me with example (TCP commands)

Please guide to connect the device to internet and post the data

Connected to internet
06%20PM

But confused that how to use post request to post data
Please help me to resolve this

Since you are able to connect to internet, Now you follow the document where it shows how to send HTTP data.

i’m getting error

AT+CHTTPACT=”http://ptsv2.com/”,80

+CME ERROR: Invalid parameter

Why did you put http:// in the URL? May be for that its giving error.

Thank U
Issue solved for that.
How can i use CTRL-Z in serial monitor arduino?

You cant type it in the serial monitor. You can use other terminal softwares like Docklight.

-Getting Network error
-Tried with different sim but the same issue
-You can see the ip address in screenshot

04%20PM34%20PM

I dont think you need to use \r\n. You just need to press enter there. \r\n is just to tell you that you press enter here when you are typing. \r\n are binary characters which are automatically inserted when you press enter.

Tried that, getting same error

Use fiddler software to test the HTTP post request first. Then try with the SIM7100 module.

I tested the same HTTP post request with Sim800 its working

Help me to figure out the issue