HTTPS on SIM900A gsm module?

Can we use https on sim900A module, I am having this pdf for reference of commands http://www.rhydolabz.com/documents/sim900_https_at_command_set_v1_00.pdf
but it is for SIM900 module, and not SIM900A.
please help
thank you

I think it supports HTTPS. You might need to enable SSL mode using AT+HTTPSSL=1. Refer datasheet for exact command syntax. Its present.

Hi sir
Iam new to embedded software domain
How can I learn and improve embedded systems & programming skills?

Please create separate topic with right heading. Dont hijack others threads.

I’ve tried using AT+HTTPSSL=1. It returns ERROR. I even tried using AT+HTTPSSL=? to check the possible modes but even that returns ERROR. What might be the problem ?

I’m using sim900a mini v3.8.2

HTTPS is normally supported by all firmwares. First make sure other normal mode commands are working , then try HTTPS.

Hello Ravi,
I am having the same problem with HTTPS. I am using sim900A module and all other functions are operating smoothly. I am being able to perform HTTP operations. But HTTPS commands are returning ERROR response. According to this datasheet (SIM900 HTTPS AT Commands Set v1.00) HTTPS in supported in Sim900A but there is no reference of HTTPSSL AT commands in the complete datasheet (Sim900 AT Commands v1.11). I am confused if HTTPS is supported in SIM900A or not. Any help will be very much appreciated. Thanks in advance.

Hello and welcome!
Since the sim900 is even older than the sim800, maybe you need to update the firmware to use these functions. Check the AT commands manual, but usually if you add “=?” at the end of the command, you can see if it’s available on your module.

1 Like

You probably have to update your firmware. I had the problem, that my newly bought SIM900 (without “A”, so no SIM900A) was on a really old firmware. I’ve used the following guide for updating the firmware (google it, I’m not allowed to post links):

basics project 070c how to update firmware of sim900 gsm gprs quad band development board shield at acoptexcom

I’ve looked for the directory with SIM900 in its name on the following site (google it):

simcom.ee/documents/?dir=

In my case it seems, that only the enhanced firmware versions for the SIM900 provide the AT command HTTPSSL.

The (latest?) version 1137B15SIM900M64_ST didn’t provide HTTPSSL, while the latest enhanced version 1137B06SIM900M64_ST_ENHANCE did.

When you use AT+CLAC, ATHTTPSSL should show up in your serial monitor of choice.

I hope this information helps more people.

1 Like