Packets on MQTT-not received

Hi I am able to connect to MQTT server…but unable to send the packets…
I used your code from the video but it dint succeed…so i had used the commands for your link
https://www.raviyp.com/embedded/226-mqtt-protocol-tutorial-using-sim900-sim800-modules-mqtt-over-tcp

got connected to it
but how to send the packets

please refer the screen shot…

The whole tutorial is about sending packets.
Your question is not clear, Please elaborate.

And the topic name cannot be a URL. Give it the right name.

Hi…The connection is getting lost frequentlly…and the way the message is received in the video…I am unable to get it on my mqtt cloud…
like in the video valetron 0, valetron 1, valentron 2 etc are received…i can see these messages on serial port…but unable to get it on cloud…
can you tell me where is it going wrong

hello sir,
actually my problem is i log in to cloudmqtt.com successfully, then i open TMFT write AT command like AT, AT+CSTT, etc but after AT+CIPSTART i get connection ok but after CIPSEND i get “closded error” please reply me as soon as possible

@pooja_shete Please open your own topic.

Lot of things can go wrong. But if you follow the video properly, you can get the data.
First you should get it working with AT commands using serial terminal, then you should try with Arduino code.

Hello Ravi…Thanks…
I used AT commands…
I have attached the screen shoot of the same…
but still not able to get the data
and also

websocket connection is being lost…

@Kirti_Yadav
Hi Kirti,

Do you observe UNDER VOLTAGE WARNING in screenshot from GSM module? That might be the reason for connection interruption. Cross check voltage supply to the module.

In datasheet they mentioned Over-voltage or Under-voltage Power off .

Datasheet here : https://simcom.ee/documents/SIM800/SIM800_Hardware%20Design_V1.08.pdf

1 Like

Hi Gangadhar…thanks for you reply…This error just came up today…But though it dint appear for earlier my trials…the connection was still not maintained for long…

If any body has tried and got succeeded with the packet transfer…can you please share the code once again…

And you are sending from Arduino terminal, Which only supports ASCII. You should send data in hex. As i do in my video

1 Like

@Kirti_Yadav

Yes as Ravi says. you can use Docklight application also to send data in HEX. Get it here: https://docklight.de/downloads/

Thanks both of you for the suggestion…I have downloaded docklight…nut please can help me out how exactly i need to proceed with it…?

Check this:

You can See this how to send commands:

Hi…Thanks Gangadhar…I tried for that too… :frowning:

You missing carriage return in commands. Although I think it is not a problem but Try to use carriage return at the end of all commands you sending. Means end of every command you need to add 0D 0A in hex format and send commands.

Hi Ravi and Gangadhar…
I tried using that too
dont know y…after sending the packet connection it says send ok and then when i go for publishing valetron, it says error and the session on the cloud gets expired

please help me out


With mosquitto is working fine

1 Like