Problem with GSM sim900A

import serial
import RPi.GPIO as GPIO
import os, time

GPIO.setmode(GPIO.BOARD)

Enable Serial Communication

port = serial.Serial("/dev/ttyAMA0", baudrate=9600, timeout=1)

Transmitting AT Commands to the Modem

‘\r\n’ indicates the Enter key

port.write(‘AT’+’\r\n’)
rcv = port.read(10)
print rcv
time.sleep(1)

port.write(‘ATE0’+’\r\n’) # Disable the Echo
rcv = port.read(10)
print rcv
time.sleep(1)

port.write(‘AT+CMGF=1’+’\r\n’) # Select Message format as Text mode
rcv = port.read(10)
print rcv
time.sleep(1)

port.write(‘AT+CNMI=2,1,0,0,0’+’\r\n’) # New SMS Message Indications
rcv = port.read(10)
print rcv
time.sleep(1)

Sending a message to a particular Number

port.write(‘AT+CMGS=“9495353464”’+’\r\n’)
rcv = port.read(10)
print rcv
time.sleep(1)

port.write(‘Hello User’+’\r\n’) # Message
rcv = port.read(10)
print rcv

port.write("\x1A") # Enable to send SMS
for i in range(10):
rcv = port.read(10)
print rcv

.
.
.
.

…above code to send SMS to my number runs, in fact keeps running until terminated with no error, balance gets deducted from SIM but i get no message.
GSM sim900A Raspberry pi3
GND GND (pin 6)
TxD RxD (pin 10)
RxD TxD (pin 8)
Do i need to change some settings on Raspberry?? why is code not working?

This can happen if you are on a Bad network. And i have seem some networks like Airtel block Outgoing messages from GSM modules whose IMEI is not white listed by them.
Some handsets reject incoming messages if the SMS is not formatted correctly.
There might be similar thread where we discussed similar problem. Try to find it. The OP might have the right answer.
For a change try the same with another module and see.