Response "ERROR" for AT+commands SIM900a

i have a problem with my sim900a
i have been flash firmware sim900a at this channel


i flash “SIM900A Firmware 1137B11SIM900A32_ST” to my sim900a but when i command “AT” response is “OK” my problem is when i command “AT+CIPSHUT” response “ERROR” “AT+CSQ” response “ERROR” “AT+CGATT” response “ERROR” anything when i command at “AT+XXXX” i have response “ERROR” can you help me about my case? thanks you


image

Hi Fajar,
Did you check the earlier version of the firmware ?
It is better to note down because some modules use 32bit firmware and some use 64 bit firmware.
To make sure that we uploaded the right firmware.
Also try the commands AT+CMGF=1 and AT+CMGL=“ALL” and ATD123456789;
To check if SMS and call functionality is working before you try the TCP commands.

hii ravi thanks for your reply
I have not had time to check the earlier version of the firmware. how to checking version firmware is use 32 bit or 64 bit ?
oke i try your suggestion. thanks

ATD12349xx; 12349 is the phone number. This command will dial the given number. You should receive a call on given number . Replace 12349xx with your cell number.

[quote=“RaviPujar, post:3, topic:138”]
123456789;
[/quos
sorry i get the same response with ATD+6289691730472 = “ERROR”

Oh, something is very wrong.
Can you try to re flash some other firmware.

i have been to re flash until 4 times but in i have same problem.

Thats not good.
What is response of AT+CREG?

Hi Ravi,

I am facing similar issue… I tried flashing multiple firmware i.e Starting from the older to newer versions, but every firmware that I tried didn’t seem to be working.

Please find below the screenshot for your reference.

When I connect my GSM Module to arduino it just doesn’t respond(May be there is other post for discussing this. :stuck_out_tongue: ). Just need to know is it because of this issue??

I have a valid tariff in the sim.

Before upgrading/Downgrading the firmware everything was working fine…(Adeno antharalla irlardid iruve bitknodange… :smiley: :smiley: ) After firmware upgrade nothing is working even if I put firmware of same version.

Status LED in GSM Module is on and network LED is blinking every 3 seconds(Which means Its receiving signals properly, Correct me if I am wrong).

Need you help here in resolving this.

Modules will be in Autobaud mode by default.
Send a capital AT command on start. It should adjust its baud rate accordingly.
You are not getting command response in terninal also after upgrade?

Still Same issue…
image

I have connected a proper power supply too.

You mean you are not getting network connection?
Are you able to ring the SIM card?

I am sure that I am getting network. The problem is I am not able to create communication between Arduino UNO and SIM900A module and I am suspecting that Firmware upgrade is the reason behind it.

Funny thing is, If I run ATD+919945XXXXXX I am getting “NO CARRIER” but when I run following commands they are running without error.

.AATDTD++991199994455550055996688


.NO CARRIER
.AT+SAPBR=3,1,"CONTYPE","GPRS"AT+SAPBR=3,1,"CONTYPE","GPRS"


.OK
.AT+SAPBR=3,1,"APN","internet , imis"AT+SAPBR=3,1,"APN","internet , imis"


.OK
.AT+SAPBR=1,1AT+SAPBR=1,1


.OK
.AT+HTTPINITAT+HTTPINIT


.OK
.AT+HTTPPARA="URL","http://www.google.com/"AT+HTTPPARA="URL","http://www.google.com/"


.OK
.AT+HTTPACTION=0AT+HTTPACTION=0


.OK
.
.+HTTPACTION:0,302,271
.AT+HTTPREAD=0,200AT+HTTPREAD=0,200


.+HTTPREAD:200
.<HTML><HEAD><meta http-equiv="content-type" content="text/html;charset=utf-8">.<TITLE>302 Moved</TITLE></HEAD><BODY>.<H1>302 Moved</H1>.The document has moved.<A HREF="http://www.google.co.in/?gfe_rd=
.OK
.

As I said earlier… running these commands from the Terminal is not important for me, I need to run same set of commands from Arduino which is Interfaced with SIM900A. Unfortunately, No response from SIM900A.

Earlier it was working fine, but when I upgrade the firmware it started giving errors. Now even if I put the same firmware I am not able to interface SIM900A with Arduino UNO.

As you are getting these command responses , module is working fine.
For ATD command, you have to use a semicolon at the end like ATD123456789;

You can use ATE0 command to stop echoing. Otherwise everything will be shown in double.
Make sure your modules baud rate (AT+IPR?) matches with Arduinos.

Thank you for your Reply Ravi, Now everything looks fine. But When I run AT+IPR? command I getting 0, I suppose I should get Baud rate in place of 0. Please find below the screenshot which explains the same.

Or can I use 9600 baudrate?? to create communication with Arduino

Got it from

Thank you for the help @RaviPujar. :slight_smile:

+IPR;0 means Autobaud mode.
You can set baud rate to same as your arduino to be sure.