Send HTTPS Get request to the server from SIM 7600 GSM module

I am trying to send a GET request to my server
www.zeonetripapi.in/phpfirebase/gsmalertget.php from my SIM7600 GSM module.

I successfully create a session with

AT+CHTTPSOPSE = “www.zeonetripapi.in”,443,2

Then I type the command to send the total number of bytes
AT+CHTTPSSEND=70

After this, a prompt appears (>) and then I type

GET /phpfirebase/gsmalertget.php HTTP/1.1 Host:www.zeonetripapi.in

No error comes but the server does not receive the request and when checked with

AT+CHTTPSSEND?

the answer comes 0 stating 0 bytes have been sent.

Kindly help me with this

Where did you found that command? I’ve checked on the AT command manual, the TCP/IP application notes and the HTTP/S application notes, and didn’t even founded it.

Have you tried following the steps in the example provided by the manufacturer on the HTTP/S Application Notes? On page 13, you can find an example for sending a GET request. I attach a capture to give you an idea.

Thank you for responding. I found those steps in SIM7500_SIM7600_Series_AT_Command_Manual_V1.08.pdf.
I also tried the steps which you have mentioned.

AT+COPS?
+COPS: 0,0,"Jio 4G Jio 4G",7

OK

AT+CSQ
+CSQ: 29,99

OK

AT+CGPADDR
+CGPADDR: 1,56.196.171.209
+CGPADDR: 2,0.0.0.0
+CGPADDR: 3,0.0.0.0,0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0

OK


AT+HTTPINIT
OK
AT+HTTPPARA="URL","www.google.com"
ERROR
AT+HTTPPARA="URL","https://www.google.com"
ERROR
AT+HTTPPARA="URL","http://www.iforce2d.net/test.php"
ERROR

But as you can see AT+HTTPPARA always returns an error no matter what URL I tried.
Can you help me with this

It seems that you are using a different way to connect to the network, compared to the proposed method in the document “SIM7500_SIM7600_Series_HTTP(S)_Application Note_V2.00.pdf” :

@viedana I tried to follow other methods too but I am stuck at AT+HTTPPARA which is not accepting anything and simply returning message as ERROR. This is the product on which I am trying the AT commands https://www.rhydolabz.com/wireless-gsm-gprs-c-130_185/sim7600ei-4ggsmgprsgps-uart-modem-rhydolabz-p-2665.html?zenid=8kd4v8mo3347m9v9dl2u3go782

That is wierd indeed. Have you tried reverting back to the beginning when you receive an error? Since the device needs the url to start with “https://” or “http://”, maybe it panics when it doesn’t receive neither. Try to reset the device, and only follow the steps in the “PDN auto-activation” and the “Send HTTPS GET request” examples, to discard any other variable (unless you have saved some custom settings on the non-volatile memory of the device).

I have no experience with the sim7600, only the sim800; that device has an extra command called HTTPSTATUS that helped you understand when it was ok to input other http commands. I didn’t find that command on the sim7600 at command manual.

The module seems ok, other than the curious detail that I couldn’t find a “sim7600ei” variant on the manufacturer website:

@viedana indeed this is weird. Can you provide the steps which you use for sending get request via your SIM800 module? I will try them out. And just FYI, I am using a 4g sim.

Shure, I followed the example in the equivalent “application note” for the sim800, Adafruit has a copy publicly available at https://cdn-shop.adafruit.com/datasheets/sim800_series_ip_application_note_v1.00.pdf that has the steps detailed at page 7. On that page, it shows how to connect to the network and send a GET request (some details are different from what I see on the for the sim7600, so there is a big chance that both methods are incompatible).

Looking around, I’ve found the AT Command Manual you seem to have, version 1.08. What surprises me is that this version has the methods you describe for HTTP, but not the ones described on the V2.00 found in the manufacturer website. The same is also true in the opposite case, the methods I’ve sent you from V2.00 aren’t found in the V1.08. What worries me, is that maybe there are large discrepancies between firmware versions of the sim7600, and in that case the source of your problems might very well be that you are not using the proper commands for your firmware version.

1 Like