SIM 800 HTTP POST with Authentication and signature

Hi I am trying to send data to a server using HTTP post method, but i cant able to add authentication and signature and other parameters on the header

below the code i tried AT+HTTPPARA=“USERDATA” is only possible to use one time, if second time use the data is over writing and only sending the last given data

looking of a solution thanks in advance

AT+HTTPPARA=“USERDATA”,“Authorization:Bearer FqDnj6Pa/zEnVHecF9DU8ZD8QnDs/vZ0qc5Oaib34YJ/pQ9oIkVudKpB4IGTuo70G4ArEnaXY4RTebk8x00E+Q==”
AT+HTTPPARA=“USERDATA”,“siteId :site_0012”
AT+HTTPPARA=“CONTENT”,“multipart/form-data; boundary=9180d67d-fb0d-47eb-a120-7baf048a019a”


problem solved

given like this

AT+HTTPPARA=“USERDATA”,“Authorization:Bearer hJJSWt3/HxYjG3vxcDsD+KJ9opfKEGV6TiXJooChYwM8kvLvGPY851yAbSgHyZw/+puAZSPg2Gx4nWEITtf/NQ== \r\n Signature: LO7PBXiX5b3o7oQS6e7PDS9H4jea5YalWAiuF+h+T9htJ7L7UKC+NwcB11wJhKGnY7nwguWfM2QDGEosyke3fw==”\r\n";

1 Like

Very interesting find! Usually, there was a bug affecting this particular parameter. The manufacturer of the chip defined that multiple parameters for the USERDATA string should be concatenated with semicolons. But on old firmwares, a bug recognized this semicolon as a new AT command, so most people had to update the firmware (this is pretty annoying).

But by concatenating the parameters with a \r\n seems like a pretty clever way to eat your cake and keep it too!

1 Like

an edit you should put two"\" infront of r and n like"\\r\\n" between the parameters you need to set

1 Like

Ok, so it seems that the SIM800 parser escapes characters. Another interesting find!

@Anoopkumar On Putty terminal if i try to seperate header items by “\r\n”(i,e by ctrl+enter,ctrl+shift+enter)i am getting error.Can we seperate header items by “,”?
which tool have you used?

Try to use “\\r\\n” in typing space it self before giving enter hope you understand