SIM 800L core board not registering to BSNL Network

Hi all, in few days i am working on SIM800L Core board, that time i am using airtel sim card and the SIM get registed on the network and everything work fine, bbut i changed the SIM card to BSNL after that its not getting register to the network and the SIM module get restarting again and again, same issue with the Vodafone sim card,

I changed different SIM cards, and Tried with different module the same result came

It is only working with the Airtel SIM, please let me know any one face this type of issues

Thanks in advance

I am facing the same problem.SIM800L core board not working with BSNL SIM card

BSNL works fine with all SIM800x modules. You might have to activate the BSNL sim after you purchased, it doesnt happen automatically. You have to call a number and press something or send a activation SMS to a number. Check the activation procedure mentioned on the SIM packet. We faced this problem with our new BSNL sim. But i dont know if yours is new or old. Try it.