Sim 900 url gets truncated issue

Hey,

i am trying to send data via http post method and my url is getting truncated .
I am using arduino uno and sim900a module.

Firstly get an error at: AT+HTTPINIT command and then when i try post, the url gets truncated

following is the code :
https://pastebin.com/TU8amwq7

and the response:

https://pastebin.com/x80ZMTsz

I am up against a deadline and would appreciate any help that you can provide.as soon as possible.

Hi,
Please remove links and paste code and images directly in site. Options are there.
The error you are getting starts at SAPBR=1,1. Its failing there, so internet is not activated when you send HTTPINIT. So make sure you check SAPBR=2,1 to see if IP address is allocated and then proceed with other stuff.
May be you are sending commands too early before module is connected to network or there is no credit on the SIM CARD.

hi, after a few changes i could get the commands working for sapbr=1,1 and http init but the url truncates amd i get bad url error . your thoughts

HX711 Demo

AT+CSQ
AT+CGATT?

+CSQ: 29,0

OK
AT+SAPBR=3,1,“CONTYPE”,“GPRS”

OK
AT+SAPBR=3,1,“APN”,“TATA.DOCOMO.INTERNET”

OK
AT+SAPBR=1,1

OK
AT+CMEE=2

OK
AT+HTTPINIT

OK
AT+HTTPPARA=“CID”,1

OK
AT+HTTPPARA=“URL”,"http://www.3dedn.com/test.php?vehicleNo= 10AT+CIPCLOSE

+CME ERROR: operation not allowed
AT+HTTPTERM

OK
AT+HTTPINIT

OK

i tried again after some modifications
and the response is as above
it either truncates the url or jump to the next command

May be you are having space in your URL. Remove it. VehicleNo= 10 .