SIM7000 URL size limit 64 bytes

Hi, I’m using the SIM7000E module, trying to use HTTPS. I thought everything was going well until I got errors which seem to be related to the URL maximum length of 64 bytes.

Surely there shouldn’t be such a small limit on the URL length? Is there any way around this issue?

Thanks in advance

Hello and welcome!

How are you determining that the URL limit is 64 bytes? Can you give more details?

Hi, thanks for the response.

I was following the attached application note, when sending the command “AT+SHCONF…” (pg. 5 on the pdf)

For some reason I’m not able to attach a .pdf or upload the file so I’m not sure how I can show you exactly where I found the information.

The following us the url: “”


Ok, and what errors are you getting? That limit does seem estrange. Can you try with the HTTP commands instead of the HTTPS commands? In this AT commands manual, on page 165, you can check them. I know it’s not the same, but those are available in the SIM800 - the one I know more of -, and are very reliable in my experience. If those work, we can discard a couple of potential problems.

It just returns “ERROR” when I try set the url, and when I keep the url short I get an “OK” response, so it must be the url length causing the errors when using “AT+SHCONF…”.

I tried using HTTP by following the "SIM7000 Series_HTTP_Application Note_V1.01 (at this url: but I get the following response:

“message”: “SSL is required to perform this operation.”

Because I am using Google Firebase, I have to use SSL, they don’t accept HTTP anymore.

I’m not really sure what else I could try?

Wow, ok. Maybe the limit is imposed by some buffer that has to store the encrypted request or something. That’s the only reason I can think for giving a more limited functionality when working with SSL.

Have you tried using an IP instead of a DNS? It should be shorter.

Yes indeed, the SIM7000E AT commands has some length limits in place. I was unable to enter the Google cloud IOT core client ID in SIM7000E MQTT connect AT command which is more than 64 bytes. A dumb move by SIMCOM.

Did you have any success trying to use the IP of the website instead of the domain name?

I guess you are asking me?
Yes i have used IP address instead of domain name for servers with static IP. But some IP addressed packets never reached server for some special cases , may be the IP address were shared for them.

Oh, ok; so it seems that changing from DNS to IP isn’t a bullet proof workaround…

Yes, It only works with static IP of providers like AWS and Digital ocean, Hosting service on godaddy provided a shared IP.

Is the url length problem still present? Even for the 7500, 7600 and so on? I need a module, which can handle TLS1.2 at least, because the SIM800L doesnt support it. I was using simple get request to send data to my server, but with the new webserver I have to use now, I’m getting

Error 606

so I need to switch to another module unfortunately.


hey @viedana I have been trying to send https get /post request and I have followed SIMCOM doc for this but everytime I use AT+SHREQ=“url…”,1 or 2
it shows SHSTATE=0


SHSTATE =1 but after I write AT+SHREQ
it gets 0 gets disconnected?


page no. 13 and 14 can you help me with this?