SIM7000E: HTTPS Error - "TCP Connect Error"

Hi everyone,

I have a SIM7000E module and am trying to send a GET request to https - dweet . io. I would like to ask if anybody has any idea why I cant open a TCP connection with “AT+CAOPEN”.

I can send a GET request to http - dweet . io using “AT+HTTPPARA” and “HTTPACTION=0”. Without SSL. So the module can definitely connect to the internet.


My commands are as follows:
AT+CPIN?
+CPIN: READY

OK
AT+CIMI

OK
AT+CGSN

OK
AT+CMNB=1
OK
AT+CNMP=38
OK
AT+CBANDCFG?
+CBANDCFG: “CAT-M”,28
+CBANDCFG: “NB-IOT”,3,5,8,20,28

OK
AT+CBANDCFG=“CAT-M”,28
OK
AT+CGNAPN
+CGNAPN: 1,“telstra.m2m”

OK
AT+COPS?
+COPS: 0,0,“Telstra Telstra”,7

OK
AT+CSTT?
+CSTT: “CMNET”,"",""

OK
AT+CSTT=“telstra.m2m”
OK

AT+CIICR
OK

AT+CIFSR
IP ADDRESS

AT+CIPPING=“googles URL
+CIPPING: 1,“142.250.204.4”,50,115
+CIPPING: 2,“142.250.204.4”,79,115
+CIPPING: 3,“142.250.204.4”,80,115
+CIPPING: 4,“142.250.204.4”,79,115

OK
AT+CDNSCFG=“8.8.8.8”
OK

AT+CNACT?
+CNACT: 0,“0.0.0.0”

OK
AT+CNACT=1,“telstra.m2m”
OK

+APP PDP: ACTIVE

AT+CNACT?
+CNACT: 1,“IP ADDRESS

OK
AT+CACID=0
OK

AT+CSSLCFG=“sslversion”,0,1
OK

AT+CASSL=0,1,0
ERROR

AT+CASSLCFG=0,“clientcert”,“client.pem”
OK

AT+CSSLCFG=“convert”,1,“client.pem”,“client.key”
ERROR

AT+CASSLCFG=0,“cacert”,“root.pem”
OK

AT+CSSLCFG=“convert”,2,“root.pem”
ERROR

AT+CAOPEN=0,“URL”,5171
+CAOPEN: 0,4

OK
AT+CAOPEN=0,“URL”,8883
+CAOPEN: 0,4

OK
AT+CLPORT=“TCP”,8883
OK

AT+CAOPEN=0,“URL”,8883
+CAOPEN: 0,4

OK


I obtained this set of commands from the list of AT Commands for the SIM7000 series document. As well as the “SIM7000 series_ SSL_ Application Note” pdf file.

As you can see, there are a few errors. Including for “AT+CSSLCFG” for converting the client cert. And for “AT+CASSL”. I do not know why these errors show.

The response to “AT+CAOPEN” command should be “+CAOPEN: 0,0”. The “4” indicates a TCP connect error - taken from the AT Command Manual.

Thank you for any responses.