SIM800 has stopped giving location information

I am using Raspberry Pi3 and sim800 module.

After setting up the GPRS connection with the following set of commands:
AT+SAPBR=3,1,“APN”,“www.airtelgprs dot com” \ Sorry the board is rejecting the post if I give correct APN syntax with ‘.’ instead of ‘dot’

and check for the IP address:

I am reading the location by the command:

I was getting the location till 2 days back.

But now the command fetches:
+CIPGSMLOC: 0,0.000000,0.000000,2019/11/29,05:00:38


Notice the latitude and longitude are missing. It’s just 0’s. It used to number till 2 days back. What could have gone wrong? I have tried deactivating the bearer profile and setting it up again by:

but no success.

Please help.

Hello bumeshrai, welcome!

I haven’t used this particular command. Can I ask you what are you using it for? As far as I know, the SIM800l has no GNSS functionality, and since this seems like an “IP” kind of command, it probably depends on an external service that provides an estimation.

If I have to guess, it’s probably also showing you the current time for Greenwich, regardless of your location. In that case “0,0” for location would make sense, since at least Greenwich is the default (a.k.a. 0) location for most location/time services. I tried in my case, and the location is also 0,0 and time is current Greenwich time.

If you are trying to get a real location, you can try to identify the available antennas around your device, at least that would give you a local estimate, although a very rough one.

I am using it for monitoring the location of a moving car in places where GPS signals are not available. It was working perfectly until a couple of days back. Time is local time as I have synchronised with local time and saved the profile.

Yes I am trying to get the location from surrounding towers. If you are getting also getting 0.0, and you are on airtel sim, then I guess I have to change the operator and check.

No, I’m in latin america, so a completely different provider. Since it depends on an external server, maybe the service has been shutdown or you are being kicked out. No real way to know. How are you setting the local time? Maybe there is an extra parameter to set, if we read the commands we might come up with something.

-I have the same problem

I use - sim800l - version with MT6261

-upgrade firmware to version 1418B05SIM800L24

-use SIM800_Series_download_Tools_Customer_v1.19

-not to use the command AT+CIPGSMLOC=1,1

-use command AT+CLBS=1,1

Interesting find! Do you know if that command is specified in any document from the manufacturer? I have no knowledge of this command.

h t t p s : //

page 8

@Andrej_S, you are right. AT+CIPGSMLOC=1,1 no more works!

But this sequence from the sim document worked for Vodafone.

Airtel still has a problem. And yes, I changed to “