SIM800 module: Network LED does not blink

Hi, I’m using sim800 module, the green LED indicating Network is not blinking, what might be the problem. How can I diagnose it?
Link for the module photo:


Note: I’ve checked the network for the SIM by inserting it into a phone and it is quite good.

Hi Kushal,
You need to check the following things,

  • Network LED blinking every 3 seconds means network is connected.
    Network LED blinking every second means that network is still being searched.
    Which is true in your case?
  • Check band settings using command AT+CBAND? It is most unlikely to be a problem but still its better to check
  • Check SIM card insertion, SIM cards these days come in cut peices for nano and micro variations so there is a good change that the SIM is not fit correctly into the slot. If you feel SIM card slot it loose, insert a small piece of paper along with SIM to hold it tight.
  • Check the antenna if its loose, tighten if needed.
  • Power supply - Most common problem. Make sure your power source can deliver 4V at 2A comfortably. What power source are you using for this module?

Hello Ravi,

  • The Network LED is completely turn off
  • I tried AT command ‘AT’ but it does not show OK and every other AT command also not working.
  • Checked for SIm looseness and inserted paper to fit but nothing
  • Antena is good
  • I tried power supply from 5V Arduino and 3.3 V Arduino (Arduino is powered by PC) and also a 12V 2A separate supply for GSM board.

Thanks for the response.

If network LED is turned OFF. You module is turned off and next steps wont make sense as the module is switched off.
The network LED should be blinking in at least one of the rates mentioned above.
12V 2A power is the way to go.
Arduino cant power the SIM800 GSM module

First we should turn on the module. Check the voltages at the VBATT pins and make sure its in operating range of the module and next we need press the PWRKEY pin to GND for 1 second to start it.
Let me know whats the result

Show us on the photo how you connected sim900 to arduino or rs232 - USB converter.

Hello Alexis,

These are the connections:

Thanks for the response.

Red circled are the RX and TX pins. Yellow circled is the 7V-15V power supply.

Thanks.

Hello Ravi,
Can you help me with locating the VBATT pins and the PWRKEY pin?

Thanks.

Hello kbad10,
You must first of all use hardware serial on arduino (RX, TX).
Also you must connect gnd between uno and sim 800 board.

I don’t know where Vbatt and PWRkey on your board, but you can find this with using multimeter, and my attachment
IMG_20170401_071329

@RaviPujar, @ALEXIS
Hi,
I tried connecting GND and PWRKEY pin, but there is no response from the module.
This is the Pin diagram for my module:

Thanks.

Do you have tll usb converter?

Measure voltage on the SIM800 module VBATT pins. And see if you are getting ~4V.

Hi, @RaviPujar, @ALEXIS,
sorry for late reply.

I checked the voltage between all three VBAT pins and ground and it is 4V. I also tried connecting powerkey and ground but still no response.

Regards,
Khushaldas

Hi !
Seems that the UART connection is there :
image

For the PWRkey if i was you i would try to remove this resistor :
image

and replace by 2 wires to a press button. Like this :
image

I don’t understant the presence of this resistor that seems to pull down the PWRkey permanently to the ground.

Hi David,
Thanks for helping out :slight_smile:
The resistor is to auto power on the module.
If PWRKEY line is pulled down to ground on power up it boots up automatically.

Thanks for the information :wink:
I think it would be useful notwithstanding to try with the push button, i’ve read somewhere that the SIM800 don’t like to be savagely powered off, it prefers a 2s pull down on PWRkey.
If we’re kind with the SIM800, the SIM800 will be kind with us.

Agreed :slight_smile: be kind

@DAgui @RaviPujar thanks for your response.
But I’m still confused on whtat I should do. Can you clarify?

Regards.

@ALEXIS I do not have tll to USB convertor.

Regards.