SIM800C echoes everything i type - Turning off echo mode [SOLVED]

Hi everyone !
I bought 2 SIM800C modules and i try to play with.
I power it with a 3000mA lipo cell, full charged, and try to communicate with a FTDI 3.3V official cable and the Docklight software.
But my issue is that the modules responds exactly what i send. Like this :
8/02/2018 07:09:56.834 [TX] - ATZ
08/02/2018 07:09:56.850 [RX] - ATZ
08/02/2018 07:23:00.509 [TX] - AT+IPR=115200
08/02/2018 07:23:00.528 [RX] - AT+IPR=115200
08/02/2018 07:23:05.298 [TX] - AT+GMR
08/02/2018 07:23:05.314 [RX] - AT+GMR

The only thing i get that seems nice is when i power down the module by pulling down the “boot” (or “link”) pin.
I get :
NORMAL POWER DOWN
I tried with my 2 modules, with and without SIM card, with and witout a 1000µF cap added…
Did someone got the same ?

Hi David ,
Modules come with echo enabled by default.
You can turn off echo by using command ATE0

1 Like

Unfortunately, it doesn’t come from this. :
08/02/2018 09:04:32.474 [TX] - ATE0
08/02/2018 09:04:32.493 [RX] - ATE0
08/02/2018 09:04:33.925 [TX] - ATE0
08/02/2018 09:04:33.942 [RX] - ATE0
08/02/2018 09:05:04.494 [TX] - Hello World :slight_smile:
08/02/2018 09:05:04.505 [RX] - Hello World :slight_smile:

But thank you anyway :smile:
Here is the modules used

Solved !
The issue came from the Docklight software !

I’ve just tried with the Arduino IDE terminal (but directly by the FTDI cable, not an Arduino board) and it works fine for both my 2 modules.

I hope it will be halpful for others :wink:

:smiley: Yeah, the terminal software has echo mode too.