SIM800C module problem

Hi
I try to communicate with the SIM800C with a 3,3V FTDI converterSim800C_Module, but most of the time the module does not respond on the UART interface. On my board
the pin called “link GND” in the picture below is called “boot”. When controlling it from a microcontroller I get a stable communication when I set the “boot” (link)
pin to low for about 1s then the communication works stable; the other pins SPK, MIC, DTR and RING are not connected.
Do you know if any of the other pins should be connected and what the “link” (boot) pin is for?

Also, when using a 5V/2A socket power supply instead of the lab power supply the SIM800 module does now work anymore. In between the power supply and the SIM800 module I am using a LM2596 voltage regulator to generate 4V. I also tried a goldcap with 0.47F on the SIM800 side, but it did not fix the problem.

Best regards
Erwin

Hi Erwin,

The module needs UART IO level translation from module to FTDI converter as the module IO levels are limited to 2.8V. If FTDI levels are 5V they can cause module to go into OVER VOLTAGE POWERDOWN.

Your setup seems ok on power side as LM2596 should give needed 2A current.
Also make sure you use thick and short wires to connect 4V to the board. If you use long and thin wires then its likely that the module keeps rebooting because of insufficient current.

A 1000uF cap on the module PIN would be sufficient.
The pin you are talking about is PWRKEY pin. It needs to be made low for 1 second and again pulled up to 2.8V to boot the module.

The DTR pin needs to be tied low to prevent module to going to sleep mode (if enabled earlier using CSCLK command)

Regards,
Ravi

Hi Ravi,

Many thanks for your quick reply.

A 3.3V FTDI converter is used, and I never got the message about OVERVOLTAGE POWERDOWN, so I think the voltage level on the SIM800 RX is OK. I tested with DTR pulled to low, but this did not change anything; I also tried to disable sleepmode with CSCLK = 0.
Maybe the problem with the FTDI converter is that I cannot generate the timing of the PWRKEY correcntly.

However, with the microcontroller (STM32 3V3) I can generate a low pulse for 1s, but the SIM800C module is still not working stable.
I have the impression that I might need to feed in some signal in the not used pins; I already have tested a few of the SIM800C modules and see this problem with all of them. It is quite diccucult to get documentation for this module…

Best regards
Erwin

Hi Erwin,
Not many connections are needed for the module to be up and running. All the VBAT pins to be connected to 4V and all GND to be connected.
PWRKEY can be kept low on startup to autoboot.
You might not see error, but it will create problems.
The module is quire simple. I have used it in almost all my products. It works great
Check here,
https://www.valetron.com/store/

Hi Ravi

I have connected these pins, but when setting PWRKEY to high the SIM800 module responds to the first AT command:
AT
OK
Call Ready
SMS Ready

and then it goes to sleep.(DTR is set to low all the time).

When set PWRKEY to low all the time then it does not go to sleep mode and the AT commands are working; I can also send data.
How would you recommend the timing of the PWRKEY signal? Should it be high at startup and then 1s low and then go high again?

Currently it works with keeping it low all the time; do you think this will cause problems?

Many thanks,
Erwin

Keeping it low all the time is not a problem. it will turn on on power up. if always low.
May be something else is acting on your PWRKEY pin.
You can just leave it to GND if it works.

Thanks Ravi,

Keeping it low works better; with the lab power suppy it works all the time now.

With the 5V/2A socket supply I cannot get it working; I have the goldcap 0.47F close to the modem (1cm wires), but I still see the modem is resetting.
Do you know if it is possible to get it working with a socket power supply; I have tried already different power supplies, but so far only the lab power supply works.

Best regards
Erwin

It means the socket power supply is not delivering what it promises. Limited current is available.

Hi Ravi,

I have tried many different socket power supplies with 2A but I can see this problem with all of them. Could you recommend any power supply which should work? I would need a small, low cost socket power supply with 5V with a european plug and ideally USB power cable.
I have attached a pic with the supply I have tried.

Many thanks,
Erwin

image

Hi Ravi,

Are you using any special capacitor on your side? It looks like the goldcap I am using is too slow; with 0.47F capacitance, there should not such a bit voltage drop. When starting to connect I can see that the supply voltage drops from 4V to about 3V for about 1ms; this is probably the problem. It should be possible to fix it with a capacitor; but I am not sure which one to use.

Best regards
Erwin

I normally use a Electrolytic 1000uF capacitor very close to VBAT pins in such cases.
But first you have to get a proper supply. I used the Actiontec adapter, it was good.
Check in this video,


I am not sure if its available at your place.

You should look at chargers for Tablets,as they have higher current charging capacity.

Hi Ravi,

Many thanks for your quick advice last week :slight_smile:
I got it working by using short thick wires and a 1000uF Eletrolythic capacitor close to the Sim800 module.

Best regards
Erwin

Glad it worked :slight_smile:

hello,

M using sim800c…i am controllinng pwrkey with my micro controller.

when i open sim lock (CPIN)… status pin of sim800c is getting low. what will be the problem. please help me out.

Regards,
Anusha

Hello and welcome! In order to keep the forum organized, please start a new topic with a detailed description of your problem so everyone can help you better and to help other people stumbling into this topic in the future.