SIM800l Httpaction. Can' get 0,200 or 1,200

I’m playing with HTTP GET and POST methods and I have problem. My problem is next one: Last week my GET method was work perfect and then suddenly stop working. Problem occur because MCU can’t got response in this format: 0,200,xxx. Code is identical 100%. MCU always got this response: 0,603 (DNS error). Next commands and responses I send/receive to/from SIM800l:

Signal strength | at command: AT+CSQ | response +CSQ: 20,0

Full functionality | at command: AT+CFUN=1 | response OK

If bearer is open send | at command: AT+SAPBR=0,1 | response OK

Otherwise do nothing

Set bearer for gprs | at command: AT+SAPBR=3,1,“CONTYPE”,“GPRS” | response OK

Set APN | at command: AT+SAPBR=3,1,“APN”,“internet” | response OK

Set USERNAME | at command: AT+SAPBR=3,1,“USER”,“telenor” | response OK

Set PASSWORD | at command: AT+SAPBR=3,1,“PWD”,“gprs” | response OK

Is bearer opened | at command: AT+SAPBR=2,1 | response +SAPBR: 1,3,“0.0.0.0”

Open bearer | at command: AT+SAPBR=1,1 | response OK

Init http | at command: AT+HTTPINIT | response OK

Enable SSL | at command: AT+HTTPSSL=1 | response OK

Set profile identifier | at command: AT+HTTPPARA=“CID”,1 | response OK

Set url | at command: AT+HTTPPARA=“URL”,“xxx/” | response OK

Set GET action | at command: AT+HTTPACTION=0 | response 0,603,0

When I got this response I send again same at command, and result is same (sometimes response from SIM800l is 0,604,0). I use laboratory psu ( which is stable and enough for SIM800l).

Stiil I can send SMS, read all messages,… without problem. What can be problem?

Hello and welcome!

Do you store the url as a constant or is it a variable that can change at runtime?

Maybe your server changed configuration and no longer accepts the insecure TLS 1.0 standard (this is the only TLS standard that the SIM800 can use)?

Are you sure the particular URL you’re using is working ok on the server side?

Are you closing the HTTP connection between connections (using AT+HTTPTERM)?

Hello viedana,
Thanks for helping me to solve this problem. URL is constant, on this forum I can’t write URL of some web-site and that’s why URL is represent in xxx format. I try with web-sites which are based on http (they are still on http protocol, they did not cross to https), same result. I try bunch different web-sites… Yea, sometimes I need to use AT+HTTPTERM, I practice to use that command with AT+SAPBR=0,1 at the beginning and at the end (if action is successful, for example MCU finish with receiving data from SIM800l).
I spend a lot of time to investigate this problem and I try diffrent soultion. some of them are: adding parallel capacitor, changed mobile operator and sim card, I buy 2 more modules (SIM800l and SIM800l evb or v2) and I got same result. Conclusion is that all modules have same fw and maybe that can be problem (I found that on one forum). And one more thing, I didn’t find current version of fw on simcom web-site.

When you try to access a http website, are you using AT+HTTPSSL=0? Also, are you sure you are using port 80 when accessing a http website?

Ok, keep in mind that you should always use AT+HTTPTERM after every connection to a server (and after you’ve gathered the response of course)

The order of operations seems to be different from the suggested by the example on this document on page 8. For example, AT+SAPBR=2,1 shouldn’t give you a “0.0.0.0”; I think you should call that command after the AT+SAPBR=1,1

I try with AT+HTTPSSL=0 and when there is no HTTPSSL , same result. Hmm what is port 80??

AT+HTTPTERM is useful on begging and on the end of HTTP sequence.

AT+SAPBR=2,1 have function to check bearer condition. If you call AT+SAPBR=2,1 before AT+SAPBR=1,1 you will always get “0.0.0.0” because bearer isn’t open. After sending AT+SAPBR=1,1 you can repeat AT+SAPBR=2,1 and then you will get address of your deveice

Yes, but it is my understanding that you should always get your device address before attempting a connection with a server.

Hello,

I found what is problem. Solution is to upgrade sim800 firmware, download SIM800_Series_download_Tools_Customer_v1.19.rar(for win) https://simcom.ee/documents/?dir=SIM800x and driver MTK_USB_DRIVER.rar. Look what firmware is currently on sim800 with AT+CGMR. My firmware was 1418B02SIM800L24. Here B02 is interested for us.

sim800l have different hardware 2 models L16 and L24. If your firmware version have L16 on the end of firmware mark download new firmware from https://simcom.ee/documents/?dir=SIM800L. Otherwise (L24) download new firmware from https://letmeknow.fr/blog/2018/01/09/tuto-update-firmware-sim8xx/. I know that is French blog but only there I find firmware for sim800l model L24. After uploading new firmware and calling AT+CGMR you will get 1418B05SIM800L24 (B05!).

1 Like