Sim800L Not connecting, rebooting sometimes

Hello all,

I have some problems with my SIM800l Module, sometimes works 6 or 7 sec and then reboots, some times doesn’t reboot at all. And mainly, I can’t connect to GPRS network to bind a TCP connection, which is the intended use.

#My setup:

I have a Sim800L coreboard, power is supplied by a laboratory power supply set at 4.0V and that can deliver up to 3.6A. The control is done via an Usb<->Serial Converter, since I want to interface it whith a C program.
Sim card is a german vodafone, without any pincode.

#My measument:

The circuit only pulls 0.10A max, which I find quite strange.
AT+CBC outputs 0,81,4049

AT+COPS? Ouputs (1,“vodafone”,“voda D2”,“26202”),(1,“BOUYGUES TELECOM”,“BYTEL”,“20820”),(
2,“SFR”,“SFR”,“20810”),(1,“Orange F”,“Orange”,“20801”),(0-4),(0-2)
Which means there is a current operator but AT+COPS=? outputs just +COPS: 1 as if there was no.

I’m really struggling since three days, maybe you have an idea

Hi Mickael,
If your USB-UART levels are at 5V and you are not converting them to 2.8V levels needed by SIM800L then reboot can occur.
Also if your power supply is having long wires from source to module, it can create problems, Keep them short.
You should check AT+CREG? for checking if network is registered or not. You can also call to the SIM number and hear if it rings.
Use AT+CSQ to find signal strength in your area.
Use good antenna so that module doesnt need extra power to pump up the signal.
Try these and see.

I hadn’t noticed the UART levels, that’s now fixed.

I tried AT+CREG?, it outputs +CREG: 0,0

The signal qquality is quite bad +CSQ: 9,0 but I had 12 yesterday

I didn’t find how to force the registration

Where is this device being tested? Germany?
Check frequency band settings using AT+CBAND?
It should say EGSM_MODE,ALL_BAND which is default value and it supports all bands over the world.
Did you try SIM from other operators?
Also check if Vodafone has 2G networks active in Germany

It is being tested at the fronteer between Germany and France, both network are available, but the sim is german.
The value of AT+CBAND? is EGSM_MODE,ALL_BAND and vodafone germany has 2G networks

I just tried with another french simcard, and the SIM800L reboots after I have given my pin code, strange

Yes that’s strange. Are you observing any power dips on VBAT line using oscilloscope?

No, constant 4.0V, but only 0.01A

Can you share a picture of the whole setup showing power connected to the module?
Also make sure that there is no current limit set on the power supply.

The wires are too long, keep them very short. Give power directly from power supply to module. Don’t go through the breadboard.
Use a 1000uf capacitor very close to module power pads if needed

Shortened the cable as much as possible, still the same :expressionless: really don’t know what to do

I can also advise adding capacitors. It sounds like brown out.
Check this carefully:


Also resistors on the reset pin perhaps?

CSQ 9 is fine to connect.

I have none at the moment, but on the oscilloscope there is no perturbation, so it should be good I think


The screen of the oscilloscope at GND and VCC when the SIM800 reboots every 9s.

I have the DTR plugged in the GND to desactivate the power saving mode, and the reset pin is not plugged to anything

1 Like

Yes it looks like voltage drop. Check if you can run at 4.2V. Then add low ESR capacitance at the power pins, the more the better. I use 5x 100uF then 100nF, 10f 33pf for decouple. . Also maybe use a different power supply… it is strange to drop so much.

Hi,
I’m working with Mickael on that case.

We checked the power supply on another circuit. The voltage is stable with no issue. Only this component is troublesome.
We also tried to power it with the 5V of a RaspberryPi and we got the same behavior.
Therefore, I don’t think the power supply is the problem.
May be something else

Hi,
Ive seen this problem many times. The device is resetting because the modules take short bursts of >2A in GPRS mode. If you do not have enough capacitance this will cause a voltage drop and power reset. See the hardware guide.
The drop is caused by the modules first attempt to transmit GPRS, then it resets and repeats.

If you see that voltage dip to 3V the device will reset. You must find and remove the cause of this, which will be hardware.

Possibly a faulty module but I have never seen that failure mode.

Hi,

We made some tests adding capacitance as you suggested. The results are even more erratic.
The module keeps rebooting but now with a random patern between 5secs and 30 secs

As @patrick77 correctly mentioned, power supply current is not enough. So the dip on the scope.
If you want to quickly solve the problem use a LiPo battery connected to module with short wires. Or find a better power source which can deliver 2A current. Module doesn’t seem faulty, its normal.