SIM808 Firmware Update Stuck at 0%(Waiting)

I am using the FTDI FT4232H Mini Module so I can do USB-UART and upgrade the firmware of SIM808 via the UART interface because the breakout board (schematic attached) I have does not support USB directly.

I am using Channel C of FT4232H Mini Module TX & RX to communicate to RX & TX of Sim808 respectively.

I followed all your instructions from the blog and the video (making sure about the baud rate etc.), and still my process get stuck in “0%(waiting)” despite when I turn on the PWR_KEY. Also from the forum, it seemed that no one has had this issue. Maybe it’s something trivial that I am missing…

I tried both 1.10 and 1.19 V of the firmware tool. I also made sure the appropriate VCP drivers were installed on my machine.

I tried Channel C and Channel D and still the same issue.

I would greatly appreciate any input on this issue. Thank you!

Are you sure the COM port you are selecting in the dropdown of the firmware update tool is the right one?
Make sure the module is in Autobaud mode.

I am using FT4232H Mini Module. I installed the VCOM drivers for it. I connected the DD0 and DD1 of the module to RX and TX of my module respectively. DD0 according to FT4232H datasheet is TX and DD1 is RX, so you crossover with the one of the module (the schematic above).

The module is in autobaud mode well. I don’t understand, I toggle the PWR_KEY but the download just get stuck.



for me AT+IPR=115200 helped for flashing (i think this was somewhere in the notes) and later AT+IPR=0 for autobauding.

I also needed several attempts with power cycles.