Sim900 sync led off

hi, im using a sim900 (te571) it has 3 leds (power, ring and sync) since the power (5vcd 2A) is connected, just the red power led turns on and the sync remains off, it doesnt blink or something,

im using a arduino nano with it.
any ideas?


Hi dude.
Can you tell witch board model you use ?
Do you get response with AT commands ?

Did you pull PWRKEY pin to GND for 1 second to boot the module?

where is the pwrkey? im just starting… i tried to get some info about the jumpers and its configuration, im connecting the sim900 it to a nano arduino and didnt get any response.

Does this board has onboard regulator below, since its taking direct 5V input?
May they have put the module in auto power ON mode.
You can check SIM900 datasheet to find out the PWRKEY pin no.

It looks similat to Saintsmart’s board.
Go there :

Click on “LEARN”, there is a lot of documents to download.
Everything about AT commands, schematics, tutorial…
The first thing to do is read manuals.

Here is Schematics :

There are pins for 5V TTL and pins for RS232 levels.
There is PWRkey pulled down, so auto start up.
There is certainly the autobauding mode by default.
So if your power source is OK for 2amps but you don’t get response after sending AT, regardless the baudrate in your terminal, check your serial/TTL adapter and check/reverse RX/TX connections.

1 Like

well it seems the cause of the sync led off was the voltage source, i change it and it works, but still have no response to the AT commands, do you have any clue about those jumpers? im connecting it to an arduino nano (pin 7 and 8) and using the next code:

#include <SoftwareSerial.h>

SoftwareSerial SIM900(7, 8); //rdx  tdx Configura el puerto serial para el SIM900

void setup()

  SIM900.begin(19200); //Configura velocidad del puerto serie para el SIM900
  Serial.begin(19200); //Configura velocidad del puerto serie del Arduino
  delay (5000);
  delay(5000); //Tiempo para que encuentre una RED

void mensaje_sms()

  Serial.println("Enviando SMS...");
  SIM900.print("AT+CMGF=1\r"); //Comando AT para mandar un SMS
  SIM900.println("AT+CMGS=\"+526562133242\""); //Numero al que vamos a enviar el mensaje
  SIM900.println("SMS enviado desde un Arduino.");// Texto del SMS
  SIM900.println((char)26);//Comando de finalizacion ^Z
  delay(5000); // Esperamos un tiempo para que envíe el SMS
  Serial.println("SMS enviado");

void loop()

  mensaje_sms(); //Envia SMS
  while (1); // Espera por tiempo indefinido

"i change it and it works, but still have no response to the AT commands"
So it doesn’t work.
These jumpers are RX / TX of the MAX232, with +12V / -12V levels. The best way to burn your Arduino board.
Il spent time to provide a lot of documentation, read it instead of trying to guess how it works.

according to the comment in your code rdx is connected to pin 7 on the arduino and tdx is connected to pin 8. With my boards the tdx is connected to pin 7 arduino and rdx pin 8.
check this link.

thanks, the problem was solved once i change the NANO by the UNO , using the same code and pins, it seems the softwareserial.h doesnt works well at nano, because i used the same code…

1 Like

3 posts were split to a new topic: Which GSM module to use in USA ? SIM900A doesnt work