TLS connection over GPRS using Pre shared keys

I want to send some data to server using SIM800A. these are the responses which i got when i tried using PUTTY terminal

AT
OK

AT+CGDCONT=1,"IP","airtelgprs.com"
OK

AT+CSTT="airtelgprs.com"
OK
AT+CIICR
OK

AT+CIFSR
100.12.01.25(local ip)

AT+CIPSTATUS
OK
STATE:IP STATUS

AT+CIPSTART="TCP","serverip","port"
OK
CONNECT OK

AT+CIPSEND
>POST localip/path HTTP/1.1
Authorization: a="XXXXX"&b="YYYY"
Host:local ip
X-M2M-Origin:GGGG
Content-Type:application/json;ty=1
Accept:application

{
{
payload data
}
^z
SEND OK

CLOSED

I am not getting the response from the server.I have added authorization field to pass pre-shared keys…can we send pre shared keys in this way ? @RaviPujar Is there any other way to send the pre shared keys ? I need to send the data over TLS connection if i enable SSL using

AT+CIPSSL=1
OK
AT+CIPSTART="TCP","serverip","port"
OK
CLOSE OK

someone please help me to resolve this issue?

You just need to use the commands shown in SSL application notes. Save the key/certificate onto the GSM module memory and instruct the module to use it to connect to server and enable SSL using AT+CIPSSL=1. The SSL application note describes all this.

Sir,
I followed the commands given in the SIM 800 Series SSL application note.
I have created filename.CRT file and Pre shared keys are written to that file and i got the response as OK but i am getting error for AT+SSLSETCERT=“file/path”,""

`+SSLSETCERT:1` import unsuccessful

what went wrong?
what should be the extension of the file?
I tried using both .key and .CRT but still i did not get…
i have been struggling with this from past months.please help me

Procedure is,
You write a file to C drive in module using FSWRITE command and then give that file name to the SSLCERT command, see the log from my device below, (Write command is not show below, refer datasheet)
.

AT+FSREAD=C:\client.pem,0,554,1

.-----BEGIN CERTIFICATE-----.MIIBazCCAR-----------------------------------OTHjQ==.-----END CERTIFICATE-----.
.OK
.OK
.AT+SSLSETCERT=“C:\client.pem”

.OK
.
.+SSLSETCERT: 0
.AT+SSLOPT=0,1

.OK

.AT+SSLOPT=1,1

.OK

Sir,
Pre shared keys which i am using are strings i,e for ex…id=“XXXXsssssssssss” and key=“YYYYYYfg67.@”
I wrote those two into the gprs in the format given in the data sheet. but
AT+SSLSETCERT="C:\User\psk.pem" did not work for me.
Those are not certificates…Is writing file content in string format correct?

Ok. For HTTP we could share the values in HTTP parameters command , I have not sent any headers over TCP. Try the request in fiddler, it will give you the raw TCP data to be sent.