Unable to connect sim800l with network

Hi. Trying to connect sim800l with network but its not connecting. Led should blink 3times/sec but it is blinking slowly 9 time then turned off then 7 times then turned off again cycle is the repeated… Power source I’m using is 4v DC 2A. Another thing I’ve noticed is ground and network GND and NET pins are short is it normal?

1 Like

Which pins are short, i didnt understand, please explain. Also look at the link David shared and make sure you have checked all the points mentioned.

image

These pins ?
No, it isn’t. Be sure they are really shorted.

Before trying to get network, start with fundamental AT commands and go step by step.
If AT responds fine, try more. If no, look at the link i’ve shared.

Yes both of these pins are short… Is it a hardware issue? What should I do to fix it.?

You should connect to the pinout " NET" Antenna, there is one reason that you can’t find network on your device. Also say what did you mean short pinout “GND”.

Network antena pin is direct connected with ground both are connected with each other multimeter is giving beep whenever I connect both of terminals. Both are short with each other

Il have 2 SIM800C modules and both have approx 1,5 Mohms measured on multimeter.
Maybe you have burned yours :confused:

Its working finally…followed all the steps tolled Ravi and Alexix… Shortened the length of wires its working now

At commands not responding… Nothing happened no responce

Yep, My bad. I was checking with probe touching metal case. There should not be a short circuit.
Thanks David. :slight_smile:

1 Like

Order another one, and follow exactly a step by step tutorial.

Can you share the tutorial

I’m working with sim800l everything seem to be ok like signal strength is 31 and i can see the network name after scanning for networks
But it’s not connecting to network
When i ran AT command to manually select network it didn’t even took time to connect. it directly shows error …
Also in automatic not connecting to network